All services impacted

Incident Report for Courier

Resolved

The incident has been resolved
Posted Oct 20, 2025 - 03:11 PDT

Monitoring

Service has been restored. Engineering is working through system review and will continue to monitor.
Posted Oct 20, 2025 - 03:02 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 02:55 PDT

Identified

An issue with our service provider, AWS, has impacted all Courier services. The engineering team is working on resolution.
Posted Oct 20, 2025 - 02:19 PDT
This incident affected: Web Application, API, Automations, Observability, and Courier Inbox.