Courier Web App Performance

Incident Report for Courier

Resolved

Fix is out and application is stable
Posted Jan 14, 2026 - 16:56 PST

Identified

The Courier team was alerted of a small degredation in the Courier web application. We have identified the issues and have rolled out a fix to mitigate. The current features will encounter some latency:
- Audience Calculation
- Audit Trail logging
We will follow up with updates.
Posted Jan 14, 2026 - 13:47 PST
This incident affected: Web Application.