Delayed Message Processing
Incident Report for Courier
Resolved
This incident has been resolved
Posted Oct 24, 2024 - 19:48 PDT
Monitoring
A fix has been implemented and delivery times are beginning to returning to expected levels. The team will continue to monitor.
Posted Oct 24, 2024 - 19:43 PDT
Update
The team identified an issue with the latest fix and reverted it. A new fix has been published to mitigate the message delay issue. ETA to land in production ~45 minutes.
Posted Oct 24, 2024 - 18:31 PDT
Update
Fix has been deployed and will be live in around 1hr.
Posted Oct 24, 2024 - 17:40 PDT
Identified
The team has identified the issue and is rolling out a fix for the message delays.
Posted Oct 24, 2024 - 17:00 PDT
Update
The team is still investigating and discussing the root cause internally. Messages are experiencing longer than normal processing times.
Posted Oct 24, 2024 - 16:29 PDT
Update
We are continuing to monitor the root cause of the delayed message processing.
Posted Oct 24, 2024 - 16:01 PDT
Investigating
Courier has identified a delay in message processing for the messages API. We are currently investigating the root cause and will update you periodically.
Posted Oct 24, 2024 - 15:38 PDT
This incident affected: API.