AWS SES Failures

Incident Report for Courier

Resolved

All impacted messages have been reprocessed.
Posted Apr 30, 2025 - 21:58 PDT

Update

The team is still working through the reprocessing for impacted messages. Confirmation of all impacted messages reprocessed will be updated here.
Posted Apr 30, 2025 - 18:06 PDT

Monitoring

Fix has landed and the team is monitoring progress. Messages sent to AWS SES are sending normally. The team will reprocess impacted messages.
Posted Apr 30, 2025 - 16:26 PDT

Update

The reverted changes will land in production in around one hour. The team will investigate the impact and handle message retries accordingly.
Posted Apr 30, 2025 - 15:47 PDT

Identified

The Courier team has identified an issue with a recent deployment that is impacting AWS SES integrations. We have found the root cause and have reverted the changes. The team is gathering impact.
Posted Apr 30, 2025 - 15:39 PDT
This incident affected: API.