Message status updates are delayed
Incident Report for Courier
Resolved
Message status updates are now being applied with no delay.
Posted Apr 20, 2023 - 16:10 PDT
Monitoring
Courier's release has completed and message status updates appear to be recovering. Courier will continue to monitor until event updates are caught up.
Posted Apr 20, 2023 - 16:08 PDT
Identified
Courier is rolling back a change that we believe is causing updates to not apply to sent messages.

Next update in ~45 minutes.
Posted Apr 20, 2023 - 15:24 PDT
Investigating
Courier is currently investigating an issue with message status updates. We believe there is no impact to message delivery at this time.
Posted Apr 20, 2023 - 15:09 PDT
This incident affected: Courier (Web Application, API).