Significant Notification Event Latency

Incident Report for Courier

Resolved

Message sends are flowing normally, and events are caught up without delays.
Posted Feb 18, 2025 - 06:47 PST

Monitoring

We're monitoring our processing pipeline as messages are flowing normally. There is a slight delay in event processing which will also impact outbound webhooks.
Posted Feb 18, 2025 - 06:29 PST

Identified

The Courier team identified a delay in message processing and event updating. The pipeline queue for message delivery has normalized, however significant slowdowns in message events are still processing.
Posted Feb 18, 2025 - 06:22 PST
This incident affected: API.