Internal Courier Error Issue

Incident Report for Courier

Resolved

All impacted messages have been reprocessed.
Posted Feb 28, 2025 - 20:11 PST

Update

The team is still working on reprocessing dropped messages caused by this issue. Send pipeline is operational.
Posted Feb 28, 2025 - 11:52 PST

Update

Messages with tags are no longer impacted, and error has been resolved. The team is working on reprocessing dropped messages.
Posted Feb 28, 2025 - 10:57 PST

Monitoring

The fix has landed in production and we will be monitoring for any more "Internal Courier Errors". We will be working on reprocessing any dropped messages caused by this issue.
Posted Feb 28, 2025 - 10:40 PST

Update

A fix has been merged and will fully deploy within the next hour. Updates to follow.
Posted Feb 28, 2025 - 09:36 PST

Update

We have tested the fix for "Internal Courier Error" and will be releasing it to production soon.
Posted Feb 28, 2025 - 09:14 PST

Identified

The Courier team has identified an issue where messages fail due to an "Internal Courier Error" in the test environment. Our team found the root cause and are working to mitigate the issue.
Posted Feb 28, 2025 - 08:48 PST
This incident affected: API.