Delayed Automation Execution
Incident Report for Courier
Resolved
The incident has been resolved. All backlogged Automations have been processed.
Posted Feb 22, 2023 - 18:18 PST
Monitoring
This issue had a broader impact that originally indicated: Instead of only automations in a "WAITING" state, all automations processing was adversely impacted.

The applied fix appears to have stabilized automations execution. Backlogged automations are now being processed. The team will continue to monitor.
Posted Feb 22, 2023 - 18:10 PST
Identified
The issue has been identified and a fix is being applied to production systems. Once the fix has been applied, backlogged Automations will begin to clear out. We will post an update in the next 40 minutes.
Posted Feb 22, 2023 - 17:19 PST
Investigating
We're are currently investigating reports of a delay in resuming execution of Courier Automations while they are in a "waiting" state.
Posted Feb 22, 2023 - 16:59 PST
This incident affected: Courier (API).