AWS serviceUnavailable Outage

Incident Report for Courier

Resolved

The team has resolved the issue. Send pipeline operational.
Posted Jun 25, 2024 - 20:12 PDT

Monitoring

Service has resumed normal operation. Courier Engineers are monitoring.
Posted Jun 25, 2024 - 19:29 PDT

Investigating

Service has re-entered a degraded state. Sends from Courier are impacted.
Posted Jun 25, 2024 - 19:02 PDT

Update

An incident where Courier messages resulted in "Internal Courier Error" was the result of AWS returning serviceUnavailable. The team has identified the issue and messages that responded with 5xx errors will be retried by our pipeline resilience.
Posted Jun 25, 2024 - 18:52 PDT

Monitoring

An incident where Courier messages resulted in "Internal Courier Error" was the result of AWS returning serviceUnavailable. The team has identified the issue and messages that responded with 5xx errors will be retried by our pipeline resilience.
Posted Jun 25, 2024 - 18:49 PDT
This incident affected: API.