Increased API Error Rates and latencies due to multiple AWS service outages
Incident Report for Courier
Resolved
AWS issue has been resolved with services operating normally. Courier systems are operational and healthy.
Posted Jun 09, 2022 - 22:08 PDT
Update
AWS is seeing a reduction in error rates and latencies. We are continuing to monitor the issue and health of the system.
Posted Jun 09, 2022 - 21:18 PDT
Monitoring
We're monitoring the AWS ongoing issue.
Posted Jun 09, 2022 - 20:59 PDT
Investigating
AWS is experiencing elevated error rates and latencies for services that affect Courier. As a result, users may see increased errors and delays within Courier APIs. So far the impact remains low and our reprocessing infrastructure is operational. We'll be monitoring this incident closely and continue to post updates.
Posted Jun 09, 2022 - 20:58 PDT
This incident affected: Hosting Infrastructure (AWS dynamodb-us-east-1, AWS kinesis-us-east-1, AWS sqs-us-east-1) and Courier (API).